Failover در میکروتیک (با استفاده از اسکریپت) post thumbnail image

Failover در میکروتیک (با استفاده از اسکریپت)

۱۳ مهر ۱۳۹۹

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم به این صورت که یک یا چند لینک اینترنت را به صورت Standby نگه داشته تا زمانی که لینک اصلی دچار مشکل شد این لینک‌ها جایگزین لینک اصلی شوند .در این مقاله به این موضوع در میکروتیک خواهیم پرداخت.

این حالت بسیار کاربردی تر از حالت اول است زیرا در بسیاری از موارد ارتباط ما وصل است ولی اینترنت به دلایل مختلفی همچون اتمام حجم، اتمام اشتراک و… قطع شده است ما در این حالت باید از script در میکروتیک کمک بگیریم. اسکریپت نوشته شده در این مقاله هر دو حالت را پوشش می‌دهد.

در این جا اسکریپت نوشته شده به این منظور است که میکروتیک به صورت خودکار لینک را عوض کند و هنگامی که لینک اول وصل شد دوباره به لینک اول بازگردد.

ابتدا کانکشن‌های PPPOE را می‌سازیم و باید تیک مربوط به Default route را برداریم. برای هر کانکشن اسمی مناسب با آن در نظر می‌گیریم زیرا این نام‌ها در اسکریپت مورد استفاده قرار خواهند گرفت.

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم

سپس به قسمت IP > Route  رفته و باید ۲ خط route جدید کنیم:

در این قسمت از یک DNS سرور که UP Time بالایی دارد مانند 4.2.2.4 یا 8.8.8.8 استفاده می‌کنیم و با استفاده از کانکشن‌های pppoe که ساختیم به میکروتیک  اجازه می‌دهیم تا تا با Gateway مورد نظر ما (لینک اصلی اینترنت) آن DNS سرور را ping کند.

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم

و یک خط route برای default route ایجاد می‌کنیم: توجه کنید در اینجا مقدار distance برابر ۲ است

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم

حالا به قسمت System > Scripts  می‌رویم در آنجا یک اسکریپت جدید به وسیله ADD ایجاد می‌کنیم. یک نام برای اسکریپت انتخاب می‌کنیم و در قسمت source این اسکریپت را وارد می‌کنیم.

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم

:global host1 4.2.2.4;
:global s; :global gw1ping [ping $host1 count=15];
:global gw [/ip route get [find comment=A] gateway];
/interface pppoe-client monitor “Shatel” once do={:set s $status} if ($s = “connected”) do={if($gw1ping > 10) do={if( $gw!=”Shatel”) do={/ip route set [find dst-address=”0.0.0.0/0″] gateway=Shatel}}} else={/ip route set [find dst-address=”0.0.0.0/0″] gateway=Parsonline};

توجه شود که در اینجا لینک اصلی ما shatel است که در صورت بروز مشکل به لینک دوم ما که parsonline است سوییچ کرده و در صورت رفع مشکل دوباره به shatel باز می‌گردد.

بعد از ایجاد اسکریپت، باید این اسکریپت رو به scheduler  بدهیم تا در بازه‌های زمانی مشخص آن را اجرا کند برای انجام این کار به قسمت  system > schedule رفته و یک schedule  جدید اضافه می‌کنیم.

Failover اینترنت به این معناست که ما برای اینکه ارتباط همیشه پایداری داشته باشیم نیازمند دو یا چند لینک اینترنت هستیم

در قسمت Name یک نام به دلخواه برای schedule اختصاص می‌دهیم. در قسمت  Start date تاریخی که برای شروع آن در نظر گرفته‌ایم و در قسمت start time زمان اجرا شدن اسکریپت را مشخص می‌کنیم و در قسمت interval  حد فاصل زمان اجرای اسکریپت است مثلا اگر در اینجا ۱ دقیقه است یعنی اسکریپت هر ۱ دقیقه اجرا خواهد شد و در آخر در قسمت on event نام اسکریپت ایجاد شده در مرحله قبل را وارد می‌کنیم .

پست‌های مرتبط

رفع فیلتر TeamViewer
همان‌طور که می‌دانید نرم افزار کاربردی TeamViewer برایIP ایران مسدود شده است. در این مقاله می‌خواهیم با استفاده از Mikrotik و بدون درگیر کردن کاربر، فیلترینگ Teamviewer را دور
تعاریف پایه‌ای شبکه
تعاریف پایه‌ای شبکه
برای درک بهتر شبکه باید با برخی از تعاریف ابتدایی آن که در عین حال کلی که به صورت مختصر آماده شده است آشنا شویم.