آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server post thumbnail image

آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server

گرفتن بک آپ از روترهای میکروتیک در شبکه‌هایی که تعداد زیادی روتر در آن‌ها وجود دارد، یکی از مسائل بسیار مهم است. گرفتن بک آپ به صورت دستی از تعداد زیادی روتر میکروتیک زمان بر است همچنین امکان خطای انسانی وجود دارد. در این مطلب قصد داریم روشی برای گرفتن بک آپ به صورت خودکار از روترهای میکروتیک و ذخیره آن‌ها برروی یک FTP Server ارائه دهیم.

۱۵ اردیبهشت ۱۴۰۱

۱. برای بک آپ گرفتن از میکروتیک، پس از Login کردن به میکروتیک از طریق Winbox، از منوی سمت چپ برروی System کلیک می‌کنیم سپس Script را انتخاب می‌کنیم. در پنجره باز شده برروی علامت + کلیک می‌کنیم.

آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server

۲. مطابق تصویر یک نام برای Script وارد نمایید و Script زیر را در قسمت Source قرار دهید. در قسمت‌هایی از Script که با رنگ قرمز مشخص شده‌اند باید اطلاعات مربوط به FTP Server خود را وارد نمایید. در انتها بر روی OK کلیک نمایید.

“log info “Starting Automatic Backup Script Configure By cr0c0dil3”
:global thisdate [/system clock get date]
:global datetimestring ([:pick $thisdate 0 3] .”-” . [:pick $thisdate 4 6] .”-” . [:pick $thisdate 7 11])
/system backup save name=”$[/system identity get name]_$datetimestring”
:log info “Please wait…!!!”
:delay 5s
:log info “Sending Backup Mikrotik to FTP Server………….”
/tool fetch address=[IP Address Of Your FTP Server] src-path=”$[/system identity get name]_$datetimestring.backup” user=[FTP Server Username] password=[FTP Server Password] port=[FTP Server Port] upload=yes
mode=ftp dst-path=”$[/system identity get name]_$datetimestring.backup”
:delay 1
:log info “Finished Backup Script…!!!!”

آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server

۳. برای تنظیم زمان بک آپ گیری باید یک Scheduler برای Script که ایجاد کردیم تعریف کنیم. برای این کار از منوی سمت چپ برروی System کلیک و Scheduler را انتخاب می‌کنیم. در پنجره باز شده بر روی علامت + کلیک می‌کنیم.

آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server

۴. در پنجره باز شده یک نام برای Scheduler وارد می‌نماییم . در قسمت Start Date و Start Time زمان و تاریخ شروع Backup را مشخص می‌کنیم. در قسمت Interval می‌توانیم مشخص کنیم هر چند روز یک بار بک آپ گیری انجام شود . برای مثال هر ۷ روز یک بار بک آپ گیری انجام شود و در انتها در قسمت On Event نام Script که برای بک آپ بر روی FTP Server ایجاد کردیم را وارد می‌نماییم و بر روی Ok کلیک می‌کنیم.

آموزش گرفتن بک آپ از میکروتیک به صورت خودکار برروی FTP Server

خدمات پسیو شبکه

ما تمام زیرساخت‌‌های لازم برای ایجاد یک شبکه کامپیوتری استاندارد را برای شما ایجاد می‌کنیم. طراحی زیرساخت شبکه، کابل کشی، نصب داکت، آرایش رک، نصب دوربین و ...

خدمات اکتیو شبکه

نصب و راه‌اندازی تمام سرویس‌های لازم برای استفاده از یک شبکه کامپیوتری استاندارد را به بهترین شکل انجام می‌دهیم. راه‌اندازی سرور، مجازی‌سازی، بک آپ اتوماتیک و ...

خدمات پشتیبانی شبکه

پشتیبانی تمام نیازهای IT شما در یک بسته جامع و مقرون به صرفه آخرین چیزی است که به آن نیاز خواهید داشت. بازدیدهای حضوری دوره‌ای، ریموت، پشتیبانی در مواقع اضطرار و...

پست‌های مرتبط
Failover در میکروتیک
Failover در میکروتیک
امروزه نیاز به اینترنت در شبکه های کامپیوتری امری اجتناب ناپذیر است به طوری که متصل نبودن اینترنت حتی برای چندین ساعت یا دقیقه می‌تواند مشکلاتی را به وجود آورد.